QuizMaker Pro 2018.2.1 (macOS)

QuizMaker Pro 2018 is a full-featured application which generates, administers, scores, and archives tests or quizzes with up to 11 different types of questions within a single test. The program can be used to print multiple versions of a single test with answer keys for each version. QMPro will administer your tests and provide detailed score analysis by individual, class, or test. Tests can be placed online for downloading and taking by students.

Possible Uses of QuizMaker Pro 2018:

In the classroom…
…create classes to group your students. Store tests in QMPro. Enable the tests as you need them or set a single test that all will take. Analyze student scores, see what questions are being missed, track how each student performs.

In the school…
…with a site license, place all data on a LAN server. Install on client computers connected to the LAN. Students are grouped by classes for teacher convenience. View and analyze all scores from any computer on the LAN (password protected).

In the home…
…take practice tests, review material for class. Learn a new subject by testing yourself. The new 'Practice Mode' allows the user to see correct answers immediately. A great tool for home-schoolers.

In the office…
…set up on individual computers or on a LAN, QMPro is an excellent tool for employee evaluations and training. Add employee numbers/ID's to the class lists for easy tracking. Email or printout user scores for maintaining records.

For the individual…
…QMPro is a great tool for studying for those important exams. Use the 'Practice Mode' for immediate feedback. Enable multiple takes of a given test to track your improvement over time. Review all misses or the entire test after completing a take. Create a new test from just your missed questions.

System Requirements:
- QuizMaker Pro runs on OS 10.9 and higher
- QMPro requires a Mac with an Intel processor
- 2 GB of RAM or more is recommended.
- QuizMaker Pro looks and runs best on a monitor capable of 1280x960 resolution



System requirements:

  • OS X 10.7 or Later



Download links: